Skip to content

Microsoft.web.redis.redissessionstateprovider does not work when EVALSHA is disabled #146

Description

@VenkateshSrini

Hi,
We are working with Redis supplied by Pivotal corp. Owing to security reasons the EVALSHA command is disabled by the provider. When we try to use that Redis with Microsoft.web.redis.RedisSessionStateProvider to persist the states I'm getting an error ERR unknown command EVALSHA. with args beginning with. This is happening for .NET applications only.

We have many .NET core applications also and those are all working fine with the same Redis cluster. The Redis server version is 2.4.1. I have tried version from 2.2.4 to 4.0.1. I'm getting the same error with all version of nuget packages.

Any insights will be of great help

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions