Repository navigation
Conversation
Co-authored-by: Copilot <223556219+Copilot@users.noreply.github.com>
Co-authored-by: Copilot <223556219+Copilot@users.noreply.github.com>
Co-authored-by: Copilot <223556219+Copilot@users.noreply.github.com>
Reviewer's guide (collapsed on small PRs)Reviewer's GuideThis PR upgrades the root Wrangler devDependency from 2.0.27 to 4.152.0, refreshes the pnpm lockfile to remove vulnerable legacy Wrangler trees, and updates the Pages deployment workflow to use Wrangler 4’s supported Sequence diagram for the Wrangler 4 Pages deploymentsequenceDiagram
participant GitHubActions
participant WranglerAction as cloudflare/wrangler-action
participant Wrangler as Wrangler_4_152_0
participant Cloudflare
GitHubActions->>WranglerAction: run(command)
WranglerAction->>Wrangler: pages deploy(dist_path, project_name)
Wrangler->>Cloudflare: authenticated Pages deployment
Cloudflare-->>Wrangler: deployment URL
Wrangler-->>GitHubActions: deployment result
File-Level Changes
Tips and commandsInteracting with Sourcery
Customizing Your ExperienceAccess your dashboard to:
Getting Help
|
|
No actionable comments were generated in the recent review. 🎉 ℹ️ Recent review info
📝 Walkthrough
Merge Risk: ⚪ Minimal · up to
|
There was a problem hiding this comment.
Hey - I've found 1 issue
Fixed security issues:
Prompt for AI Agents
Please address the comments from this code review:
## Individual Comments
### Comment 1
<location path="package.json" line_range="46" />
<code_context>
"@vitest/coverage-v8": "catalog:",
"web-ext": "^6.8.0",
- "wrangler": "2.0.27"
+ "wrangler": "4.152.0"
},
"engines": {
</code_context>
<issue_to_address>
**Pages deployment fails**
When a caller or manual dispatch selects Node below 22, `__deploy-pages.yml` forwards that version to `setup-node`, which runs Wrangler 4 on an unsupported Node runtime and fails before deployment, so the Pages site is not deployed.
Constrain the selected Node version to 22 or newer before running Wrangler.
</issue_to_address>Sourcery assessment
Needs a human reviewer. 1 finding to address first, and the updated Wrangler CLI command and version are used to publish Pages deployments, so an incompatibility or changed deploy behavior could put a broken site live. Reverting prevents future runs from using this setup, but does not undo a deployment already published; restoring the previous site would require another deployment.
Blocking findings: package.json:46
| "@vitest/coverage-v8": "catalog:", | ||
| "web-ext": "^6.8.0", | ||
| "wrangler": "2.0.27" | ||
| "wrangler": "4.152.0" |
There was a problem hiding this comment.
🟡 Medium · Pages deployment fails
When a caller or manual dispatch selects Node below 22, __deploy-pages.yml forwards that version to setup-node, which runs Wrangler 4 on an unsupported Node runtime and fails before deployment, so the Pages site is not deployed.
Constrain the selected Node version to 22 or newer before running Wrangler.
Prompt for AI agents
In `package.json` at line 46:
**Pages deployment fails**
When a caller or manual dispatch selects Node below 22, `__deploy-pages.yml` forwards that version to `setup-node`, which runs Wrangler 4 on an unsupported Node runtime and fails before deployment, so the Pages site is not deployed.
Constrain the selected Node version to 22 or newer before running Wrangler.
Upgrades the root
wranglerdevDependency from 2.0.27 to 4.152.0 (removes the vulnerable wrangler 2/3 trees).cloudflare/wrangler-actionuses the repo's pre-installed wrangler when nowranglerVersionis given, so this is the version CI deploys with.pages publishis a deprecated hidden alias; switched__deploy-pages.ymltopages deploy(already used inexperimental-release.yml). Verifiedwrangler pages deployexists in 4.152.0 locally.Cannot be fully verified without Cloudflare credentials; the first master deploy is the real test.
Stacked on #3345/#3344 lockfile changes; rebase after they merge.
Summary by Sourcery
Upgrade deployment tooling to Wrangler 4 and use its supported Pages deployment command.
Bug Fixes:
Enhancements:
Summary by CodeRabbit